Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Closed Captions not working correctly in playlists

Sorry, I didn't really think that any of the topics really fits to my question, so I just left the initial one selected. I hope that's fine.

I have a problem using closed captions in playlists. I do not intend to use them for subtitles or something like that, Since there is no actual playlist field any longer, I wanted to use them to give some quick information about the clip to the viewer. I am a voice over artist and want to create an 'overlay' pointing to my role in a certain clip.

I am using a dashboard player and the delivered player libary url , embedding the player on my site manually. of course, the vtt-files are present and all paths etc. were checked like a trillion times. ;-)

now my problem ist this:

first it looks like everything is working fine. the vtt-content appears on the set timecode defined in the vtt-file. But this only works for the very first item of my playlist. (no rss playlist, just a regular player with playlist items...)
When the player hops over to the second clip, the player again shows the content of the first vtt-file, not the second one, even though there ist a different vtt-file set for that playlist item. the same thing happens with every other item in the playlist after the first one. this happens on all players on all pages and subpages, no matter what the content is. I checked the current versions of safari, firefox, chrome and yes... even edge... they all behave in the same way.

of course I also changed playlist positions of certain clips for testing purposes. just to see if i may have had a typo or a wrong path in there, even though I checked that multiple times.
let's say, I moved clip #3 of the playlist to the first position, then clip #3's vtt-content is being displayed correctly, when it is on position one. And again, for all following items in the playlist only the vtt-content of the first item ist shown. Even the "old clip one" that was now moved back to put another clip on position one does not work anymore...

I am having this problem for quite a while now, I have already posted about it and there were quite some people that had the very same prblem. it is really frustrating, because I am really happy with the player... for years and years now. support has always been outstanding. it would be great if seomone could help me and point me into the right direction.

It doesn't make sense to provide a link right now, since I wiped all the closed caption/vtt stuff for the time being. As I said, I am using my website as customer info and demo real for my voice over and voice acting work, so it would leave an unprofessional impression if something like that displayed wrong information... for months... ;) so I removed it.

If you need to see a demonstration of the issues I am having, no problem! It ist set up in seconds, since i just need to rename a few files to "reconstruct".

Thank you very much in advance

2 Community Answers


JW Player Support Agent  
1 rated :

Hi, there.

Can you please supply a link to a reproduction page so we can take a look at your issue?

Thank you.


0 rated :

Hey Alex,

okay this is weird and a little emberassig. I just tryed to reproduce the behaviour yesterday, like I did so many times before. Put those vtt-files in place and styled the cc's a bit and... it worked like npthing ever happened. I have no idea why because I am not aware of anything I did differently! :-o
But, well, there must have been a difference I guess... because it works now.

Thanks for the response and the will to help me out, but... it works just like intended right here in the player on the main page:

Just need to replace the rest of the youtube-stuff with self hosted content, but that's it.
Thank you very much though! ;)

This question has received the maximum number of answers.