Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

How to set up HLS streaming with Wowza. Chrome and Firefox not working.

I am running Wowza 4 to stream live video and using JW Player PRO for playback. I would like to set up adaptive bitrate using HLS streaming.

Currently, I can playback the stream on Safari, but not on Chrome / Firefox. I am getting the error: "Playlist could not be loaded: No playable sources found."

I followed the video tutorial on this page and setup the transcoder and SMIL file:

My SMIL file (twtest.smil) looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<smil title="Teaching Window Test">
<video height="720" src="myStream.sdp_720p"
systemLanguage="eng" width="1280">
<param name="videoBitrate" value="1300000" valuetype="data"></param>
<param name="audioBitrate" value="44100" valuetype="data"></param>
<video height="360" src="myStream.sdp_360p"
systemLanguage="eng" width="640">
<param name="videoBitrate" value="850000" valuetype="data"></param>
<param name="audioBitrate" value="44100" valuetype="data"></param>
<video height="240" src="myStream.sdp_240p"
systemLanguage="eng" width="360">
<param name="videoBitrate" value="350000" valuetype="data"></param>
<param name="audioBitrate" value="44100" valuetype="data"></param>

My JW Player setup looks like this:

image: "",
sources: [{
file: ""
androidhls: true,
autostart: true

As I said, this works on Safari... but not Chrome or Firefox. Any insight would be appreciated.

3 Community Answers


1 rated :

HLS on desktop is a premium edition feature:

James Herrieven


JW Player Support Agent  
2 rated :

Safari can natively play HLS streams but Chrome and Firefox cannot. As James mentioned, you would need a Premium license of our player in order to enable our player’s ability to play the HLS stream via the Flash plugin in browsers that do not natively support HLS.


0 rated :

I see. Thanks for the quick reply guys, I'll the upgrade asap and report back.

This question has received the maximum number of answers.